Ubuntu

From ActiveWiki
Revision as of 01:39, 23 March 2015 by Chrispeg (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Running ActiveWorlds 6.2 on Ubuntu Linux.

Ubuntu1.jpg
All that is needed is Wine 1.7.31+ out of the box and the standard ActiveWorlds Online Installer.


Download

  • Download Wine 1.7.31 or later via Ubuntu's built-in App Mananger or directly from WineHQ.
  • Download Q4Wine via Ubuntu's built-in App Mananger.
  • Get the ActiveWorlds Online Installer for Windows from AW.

Setting up Wine 1.7+

  • Install a 32 bit Prefix of Wine - Wine64 is not stable enough.
  • Set Windows version to Windows 7.
  • Optionally override d3dxof.dll, wininet.dll and quartz.dll via Winetricks for best experience.
  • Run the ActiveWorlds Online Installer for Windows.

Support

  • Activeworlds, Inc does not support Linux installations to individual persons.
  • Ask the AW Community at the AW-Forums.
  • Find help at winehq.org and its forums.

Known Issues

  • Wine earlier than version 1.7 can not deal with mouse clicks into the 3D window.
  • Wine earlier than version 1.7.32 do not draw window decoration correctly for tool-window styles - used by the option-settings property pages.

Hardware Requirements

  • Intel 2.4 GHz Quad Core CPU or better
  • 6 GB RAM min recommended
  • 6 GB or more of free disk space
  • NVIDIA® GeForce® 320M, ATI Radeon™ HD 6630M, Intel® HD 3000 or better

Software Requirements

  • Ubuntu 14.04 LTS or later
  • Decent 3D Graphics driver(!)
  • Wine 1.7.31 or later
  • Q4Wine or similar tool to setup a prefix
  • ActiveWorlds 6.2 build 1400 or later


Additions for other Linux versions

Self compiled versions of Wine, or Wine on other Linux than Ubuntu, require Core Font package from winetricks installed to get CEF Chrome Embedded Framework working. Manually install Flash if needed.